It is currently Fri Jun 14, 2024 6:02 pm



Game servers 82 List provided by EpocDotFr | Players online 246

All times are UTC

Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: RWR wont run
PostPosted: Sat Aug 10, 2019 2:16 pm 

Joined: Sat Aug 10, 2019 2:15 pm
Posts: 1
When running the game steam says it is launching Running with Rifles, but then nothing happens. If I try to select "Configure" it says "Missing OpenAL library. OpenAL is required to run RUNNING WITH RIFLES. Unable to find openal installer."

I ran the openal installer, that I got from here, and it said install complete. I restarted the computer and my nvidia drivers are up to date. But it is the same problem still; getting the same error as mentioned above.

Also when I try to run the RWR exe file directly from the install folder it says OpenAL32.dll is missing. I looked in windows/system32 folder and openal32.dll is there.

I dont know how I can proceed now? I tried deleting and reinstalling the game again, but it is the exact same problem :(

EDIT: Tried deleting the openal32.dll file from windows/system32. Then tried running the openal installer. Now the OpenAl32.dll appeared and the game can start. However, there is no sound in game :(

 Post subject: Re: RWR wont run
PostPosted: Fri Aug 16, 2019 6:20 am 
Site Admin

Joined: Mon Jun 27, 2011 11:59 am
Posts: 2856

It looks similar to a case I've seen happen before to a couple of players, where an old OpenAL installation refuses to uninstall when installing a newer OpenAL, causing OpenAL update to fail.

Please try this:
There could be an OpenAL version conflict when that happens.

You could try specifically uninstalling OpenAL first, on Windows 10 you can go Control Panel -> Programs -> Programs and Features and there uninstall OpenAL. After you've uninstalled it, please verify that OpenAL32.dll and wrap_oal.dll are no longer existing in C:\Windows\System32\. You may also need to reboot at this point. I remember a rare case where getting those files uninstalled normally didn't just work, also e.g. here ... VED-Forums someone had to manually delete those dll's for some reason.

After the OpenAL dll files are removed, install OpenAL again. There's a copy of the correct installer provided at C:\Program Files (x86)\Steam\steamapps\common\RunningWithRifles\Redist\OpenAL\, oalinst.exe, run it and then try to run RWR again.

Oalinst.exe you got from is same as the one provided with RWR in Steam folder.

Let me know if it doesn't work!

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC

Who is online

Users browsing this forum: No registered users and 35 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group